login about faq

How can I force a hostkey to be added automatically to my ~/.ssh2/hostkeys directory? The option

-o StrictHostKeyChecking=no

doesn't seem to be available, and I couldn't find a ssh-keygen(1) either, so what would be a proper way to do this with Tectia?

asked Mar 02 '15 at 17:47

Andi's gravatar image

Andi
6114

edited Mar 02 '15 at 17:53


Andi,

Please try the following option instead for the newer Tectia Products.

--hostkey-policy=policy Set hostkey policy: ask, strict, tofu or advisory.

tofu is probably the one you want to use, it stands for Trust on First Use.

advisory disables the host key check all together for all connections (not recommended).

Regards, -Joe

link

answered Mar 02 '15 at 18:16

Joe%20-%20Tectia%20Support's gravatar image

Joe - Tectia Support ♦♦
55215

That option --hostkey-policy=tofu is exactly what I was looking for, thanks a lot Joe!

(Mar 03 '15 at 10:00) Andi Andi's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×29
×17

Asked: Mar 02 '15 at 17:47

Seen: 3,854 times

Last updated: Mar 03 '15 at 10:00

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.