login about faq

I have tried ssh-keygen-g3 -i -f my_tectia.pub > my_openssh_key.pub but I get the following error: "Error: Cannot determine the type of the key." Can anyone help?

asked Oct 18 '12 at 00:17

highbytes's gravatar image


Hello, please use OpenSSH's own keygen tool to convert the key format.

Something like:

sshg3 ServerUser@openssh_server "ssh-keygen -i -f id_dsa_2048_a.pub >>.ssh/authorized_keys"

Please note that both, Tectia Client and Tectia Server, can understand both key formats, RFC4716 and OpenSSH formats.


answered Oct 18 '12 at 01:06

Sami%20Marttinen's gravatar image

Sami Marttinen ♦

I am having the same issue on RHEL 6.2 - have SSHTectia client 6.2 installed and ran the ssh-keygen command to generate the public key.And when i run the below to convert the public key in Openssh format, get the below error - not sure I understood the above post

bash-4.1$ ssh-keygen-g3 -i -f id_rsa_2048_a.pub > authorized_keys2 Passphrase : Error: Cannot determine the type of the key.


answered Oct 22 '12 at 19:31

gerjesjo's gravatar image


Please note that you will need to use OpenSSH's own "ssh-keygen" tool for the conversion operation.

Regards, SamiM


answered Oct 24 '12 at 00:39

Sami%20Marttinen's gravatar image

Sami Marttinen ♦

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Oct 18 '12 at 00:17

Seen: 6,794 times

Last updated: Oct 24 '12 at 00:39

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.