login about faq

i am running SSH client v6.1.7 on winxp and SSH Server v6.1.7 on window 2003.

i am able to use password authentication to login to the server but i cant get a public key authentication to work.

i have successfully uploaded the public key to .ssh2/authorized_keys and have enable password authentication on server and client but i still cant get to work. The server user configuration directory is %d\.ssh2 and Public-Key Authentication is allow. Tectia server setting on Authorization file: %d/.ssh2/authorization and authorized-keys directory: %d/.ssh2/authorized_keys.

SSH Tectia client status : broker_userauth_method_failure, "publickey", session-id:7

SSH Server event log :

  • 701 Auth_method_failure, Username: abc, Auth method: publickey, session-id:46
  • 708 Publickey_auth_error, Username: Lion\abc, Algorithm: publickey, "Could not find the received public key in user's public key authorization file or directory". sesson-id:46

Appreciate if anyone can advice on this.

asked Sep 03 '10 at 09:39

Joseph's gravatar image


edited Sep 03 '10 at 12:08

Roman's gravatar image

Roman ♦♦

Did you upload the public key using the wizard in the Tectia Client configuration GUI, or did you do this manually?

(Sep 03 '10 at 09:44) Ville Laurikari Ville%20Laurikari's gravatar image

Hi, i have tried upload the public key using the wizard in Tectia Client configuration GUI. i have also tried using command line and manually too.

(Sep 06 '10 at 01:31) Joseph Joseph's gravatar image

I had this issue crop up yesterday and was disheartened to find no answer to the problem. I think I have found one possible answer today. In the system log files you will likely see another error around "Could not find the received public key in user's public key authorization file or directory" that reads something like "Bad access modes for publickey file '/home/<uname>/.ssh2/name.pub'." followed by "Access modes or ownership of the user's publickey file '/home/<uname>/.ssh2/name.pub' are incorrect."

Note that the key that was being moaned about was NOT the key I was trying to use with my account. So here is what I think happened. When ssh cycled through the keys in my authorization file PAM found a key with bad permissions and immediately bailed my connection and asked for a password. As soon as I changed the permissions for the offending public key everything worked.

Hope this helps someone. Best regards.


answered Jun 02 '11 at 13:31

boneman147's gravatar image


I just started having this issue as well. Has anyone found out what the issue is?


answered Feb 11 '11 at 13:42

ninja-neer's gravatar image


Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Sep 03 '10 at 09:39

Seen: 12,909 times

Last updated: Jun 02 '11 at 13:31

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.