login about faq

My Centos server is configured with UTF-8 encoding. When I open a command line window with SSH Secure Shell on my PC to access my server, all accented characters are badly displayed. Is it a way to configure SSH Secure Shell to fix this problem ?

asked Jul 24 '12 at 15:52

Robert%20Gervais's gravatar image

Robert Gervais
1111


Hi Robert,

what do you mean by: "with SSH Secure Shell on my PC"? Do I assume right: Tectia SSH of version around 3.x and some kind of Windows platform? The other important question is: what do you mean by "command-line window"? Do I suppose right that you mean "cmd.exe" (the windows console)?

If my assumptions are right than you are screwed I am afraid. But perhaps not completely. Read below.

First of all versions 3.x, 4.x, 5.x, and 6.0.x are not supported anymore and character set conversions are not implemented there. You should look for current version 6.3.x.

When you connect using Tectia SSH Client and Server both on some kind of UNIX/Linux platform, then you have more hope. If both client and server use UTF-8 all is fine. Or if both use any other encoding (but the same on both ends) all is fine too. Current sshg3 client (6.3 and 6.2 also, not sure about 6.1 now) has undocumented command-line options for character conversions. They are not documented, because the implementation is not complete and may change quite a lot. But the basics work. Here is an example command you can try to use:

sshg3 --remote-charset=utf-8 --local-charset=windows-852 --charset-conversion=force user@unixserver

There is one more useful argument: “--list-charsets” which will do what it says. List all available charsets.

By default sshg3 does not do conversions at the moment (the feature is not complete) so you have to specify “--charset-conversion=force”.

I believe this will work fine on Unix like systems. Our z/OS version has similar feature enabled and documented I believe. But Windows implementation is not tuned with the buggy crappy Microsoft Console implementation. The Windows console does not really work with Unicode. So there you could try to choose a character set of your choice (the Windows locale for non-Unicode programs) and hope that characters from that set are enough for you.

The Windows GUI Terminal client does not support any character set conversions at the moment. So your only hope is to have the same ANSI code page (from locale for non-Unicode programs) on both Client and Server.

It is a shame that Tectia does not work with Unicode on Windows yet (in 2012?), but our resources are extremely limited and there are always “some more urgent” features and bug fixes to do as it seems.

If you are an employee of some of our key customers, ask your boss to push my boss ;) I would like to have this feature there too!

I am not sure if this helped.

I am ready to answer more questions on this topic.

With regards

Martin

link

answered Jul 25 '12 at 00:00

Martin%20Dobsik's gravatar image

Martin Dobsik ♦
484126

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2
×1

Asked: Jul 24 '12 at 15:52

Seen: 6,948 times

Last updated: Jul 25 '12 at 00:00

Related questions

All user contributed content licensed under the cc-by-sa license.
Powered by OSQA.